M

mibrahim

Member

Last active last year

  1. last year
    Tue Feb 2 12:28:02 2016

    yes, I am using this fix in order to compile sodbg with gcc-4.9

  2. Tue Feb 2 09:19:44 2016

    Well, I made some trials this morning. I tried to compile without any modifications in abstract_dcas file, so let me add some updates.
    1- this 'silence' was because of I am running the following
    make -f makefile.linux -sorel
    but I tried running this: make -f makefile.linux sorel it started to compile and displaying what is happening during compile process.
    2- the surprising thing for me today is gcc-4.9 is able to compile " make -f makefile.linux sorel" but not able to compile "make -f makefile.linux -sorel" (that is because -sorel is not recognized by the make file so it is treated as default option "dbg").
    3- then I ran "make -f makefile.linux clean" then clean is now working (previously I was running "make -f makefile.linux -clean")
    4- then I ran "make -f makefile.linux sodbg". I found that gcc-4.9 is not able to compile (gives impossible operand error) but only gcc-4.4 is able to compile it.

    So I concluded that gcc-4.9 is able to compile for "rel" but not for "dbg". If I want to run for "dbg" using gcc-4.9, I should modify abstract_dcas file as you suggested.

    I have no problems so far, I understand now how to work around this compile process. just wanted to add this update

  3. Mon Feb 1 10:35:42 2016

    Hi,
    Sorry for my late response , I was involved actually in another project last week. well I tried this modification and THANKS alot, it has been compiled. I have the following observations:

    • I replaced arm section of abstraction_dcas.c file with the one that you provided.
    • I ran make -f makefile.linux -sorel PREFIX=/path/to/target/directory in order to get header in "include" and .a output in "lib" directory

    Now what happened is:

    • no response was observed in terminal interface (nothing indicates if successfully finished or failed).
    • I can see object abstraction_dcas.o now is created in obj directory.
    • I found liblfds.a in 'bin' directory (not the directory specified in PREFIX) (so I will copy from bin to lib directory no problem in that)
    • I tried to run make clean but this is not acceptable, it tells me "no rule for make clean ..".

    So we can say that it works for me now, I just wanted to add my observations , I don't know if you have the same or not.
    I really appreciate your support and help for making this solved.

    Thanks

  4. Tue Jan 26 13:56:39 2016

    yeah sure, feel free to change it.

  5. Mon Jan 25 15:56:42 2016

    I tried again with liblfds7.0.0. currently it compiles successfully. well, I don't know what makes it works, the only thing that I changed in my system is installing protobuf library which is installed along with (autoconf-automake-libtool) libraries so I have no idea actually if this has effect or not.

  6. Mon Jan 25 13:12:22 2016

    Hi,
    Thanks alot for your quick and detailed response. I would like to give you also some information that may help while debugging this issue.
    Actually couple of months ago I was using raspbian "wheezy", default compiler for this raspbian-wheezy was gcc-4.3. I tried to compile liblfds but it failed. however we made update for the compiler (from 4.3 to 4.8) then liblfds was compilied successfully.
    This time I am working with raspbian "jessie", I tried then to compile liblfds with updated compiler (4.9) then I got the error that is explained before.
    I tried to compile with version gcc-4.8 as we used in previous raspbian, however this time I got another error message : error: can’t find a register in class ‘CORE_REGS’ while reloading ‘asm’.
    I also tried to compile liblfds 7.0 but I got the same error.
    I hope this info might be helpful.
    Also regarding migrating to work with other version of liblfds, you are right, the code is based over liblfds 6 however it is still big hassle to change lib and functions names in all source files as well as non-arm version of the code is already working on liblfds 6.
    Thanks again for your support,
    Mohammed

  7. Mon Jan 25 08:58:09 2016
    M mibrahim started the conversation Compile Error with release 6 (six) in RaspberryPi.

    Hello,
    I have a problem in compiling liblfds (version 6) in raspberry pi2 board. This board is using ARMv7. I am running Raspbian as the operating system (linux kernel of this raspbian is 4.1.15). I am compiling on Raspbian with gcc compiler version 4.9. GNU make version is 4.0.
    I get an error in function abstraction_dcas, " asm function has impossible operand".
    could you please advise how to resolve this problem.
    also note please I am allowed to use version 6 only (not 6.0 nor 6.1) as our SW was built on this version.

    Thanks in Advance,

  8. Tue Jan 19 15:45:35 2016
    M mibrahim joined the forum.